13°
15:46

WiFi PCI Compliance

The airport’s WiFi service has recently been updated to ensure it is fully compliant with the Payment Card Industry (PCI) Data Security Standards.

The PCI Data Security Standard is a global standard and applies to companies of any size that store, processes or transmits cardholder data.

Impact to service
Some older browsers may not meet these standards any longer and therefore users will need to use a browser that meets the PCI Data Security Standards, as follows:

  • Microsoft Edge
  • Chrome v38 and above
  • Firefox v27 and above
  • Android Browser on Android 5.0 and above
  • Safari on OS X v7 and above
  • Safari on iOS v5 and above
  • Internet Explorer 11 and above
  • Samsung Internet 4 and above